OpenCL Apple demos

Discussion in 'Rendering Technology and APIs' started by oscarbg, Nov 5, 2009.

  1. oscarbg

    Newcomer

    Joined:
    Sep 2, 2009
    Messages:
    35
    Likes Received:
    13
    Following Voxilla DirectCompute demos I have ported OpenCL Apple demos to Windows..

    Also similar to GPU-z and CUDA-z I have fixed and early OpenCL-z port adding some features to the mix..

    The executables are finally compatible with AMD CPU and GPU and Nvidia CPU implementations.
    and compatible with ICD model so futureproof for other imp

    They require latest drivers (nvidia 195.39, ati 9.11)
    and in case of nvidia are able to get up to 2x speed up using efficient OpenGL interop!

    See http://oscarbg.blogspot.com/2009/11/port-of-apple-demos-to-windows.html
    See http://oscarbg.blogspot.com/2009/11/opencl-z-is-here.html

    Trying to get also in Linux ..
     
  2. Voxilla

    Regular

    Joined:
    Jun 23, 2007
    Messages:
    832
    Likes Received:
    505
    Nice ports :wink:

    It's amazing how Apple managed to mess up the quaternion Julia renderer.
    There are plenty of artifacts that should not be there.
    My first port was also based on Apple's port, later I ported from the original Cg source of Keenan Crane as it has none of those rendering bugs.
     
  3. Lightman

    Veteran Subscriber

    Joined:
    Jun 9, 2008
    Messages:
    1,935
    Likes Received:
    914
    Location:
    Torquay, UK
    Seems not to work under W7 x64 ....

    Both OpenCL-z and Apple ports are saying no OpenCL.dll can be found :cry:

    I'm using Beta Cat.9.11
     
  4. IRQ Conflict

    Joined:
    Apr 13, 2005
    Messages:
    64
    Likes Received:
    0
    Location:
    DV,AB,Canada
    I must not be doing it right either. I just assumed OpenCL was part and parcel of Cat9.11. Vista 64same result.

    Edit: I should mention I'm using a 4890 not any 5xxx series card. If that has any bearing on it?
     
    #4 IRQ Conflict, Nov 7, 2009
    Last edited by a moderator: Nov 7, 2009
  5. guardian

    Newcomer

    Joined:
    Jul 3, 2008
    Messages:
    12
    Likes Received:
    0
    anyone knows if i have a chance to get this running on a radeon 4850 with catalyst 9.11?
     
  6. Arnold Beckenbauer

    Veteran Subscriber

    Joined:
    Oct 11, 2006
    Messages:
    1,666
    Likes Received:
    633
    Location:
    Germany
    Of course:
    [​IMG]

    But you need the ATI Stream SDK 2.0 beta 4.
     
  7. guardian

    Newcomer

    Joined:
    Jul 3, 2008
    Messages:
    12
    Likes Received:
    0
    btw did you publish the code in the end?
     
  8. oscarbg

    Newcomer

    Joined:
    Sep 2, 2009
    Messages:
    35
    Likes Received:
    13
    No promises..
    I have some changes for it probably this or next week:
    changelog

    =========



    1.new apple code: includes apple fft lib, apple ocean demo and histrogram demo

    all the other code: prefix sum, reduction..



    2.Includes linux port

    source code coming with linux someday



    3.fixes for amd 2.0 sdk:



    a.fixed icd for ati

    b. fixed order opengl buffer creation after cl context for ati gl interop



    3. fixed select nbodies

    4. option force gl for ati supports gl but no gl_sharing

    5. fullscreen option default yes

    7. show displays attached or no on displa demo

    8. change fov 70 to 60 grass

    9. hay bug win64 due to glut glutswapbuffers

    fixes noise kernel __wr-> __write_only seems Apple and Nvidia accept it



    fixed by ati 2.0:

    1.image support noise

    2.cypress nbody

    3.grass animated works gpu now

    4. works gl interop with nvidia card in ati opencl gpu

    but only in no texture gl interop (grass,displacament)



    note amd 2.0 final seems cal and opencl gpu works without extending monitor onto it

    (no its false)

    also icd works no nvidia but yes multiple opencl ati platforms for checking
     
  9. Talonman

    Newcomer

    Joined:
    Jan 2, 2010
    Messages:
    64
    Likes Received:
    0

    I get the same error running Nvidia GPU's and W7 x64.
     
  10. neliz

    neliz GIGABYTE Man
    Veteran

    Joined:
    Mar 30, 2005
    Messages:
    4,904
    Likes Received:
    23
    Location:
    In the know
    give me a sec to try w7-64 - HD5850.
    nbodies crashes, the rest fail to find any OCL device. the SDK demos and converted R700 demos run fine :/
     
    #10 neliz, Jan 17, 2010
    Last edited by a moderator: Jan 17, 2010
  11. oscarbg

    Newcomer

    Joined:
    Sep 2, 2009
    Messages:
    35
    Likes Received:
    13
    a.fixed icd for ati
    wait some days
     
Loading...

Share This Page

  • About Us

    Beyond3D has been around for over a decade and prides itself on being the best place on the web for in-depth, technically-driven discussion and analysis of 3D graphics hardware. If you love pixels and transistors, you've come to the right place!

    Beyond3D is proudly published by GPU Tools Ltd.
Loading...